In regards to ongoing rubber banding
#1
So lately I know a lot of you have been complaining about the lag. I've been seeing it too, and I'm directly connected to the server. I've been checking disks, checking memory, replaced the NIC, and yet we're still having issues. 

The NIC replacement seemed to do the most good, but it seems things still degrade over time. 

I started checking the SSD's with 'smartctl --all' on Ubuntu, and everything looks fine from that angle.

None of the other servers seem to be having any issues.

I'm not sure where to go next.
Support MineTexas, Buy Plus
Shop our Cafe Press Store
Or shop our Amazon Affiliate store.
Reply
#2
I would offer some advice, but i understood less than half of the words in your post XD.
Science, Bitch!
Reply
#3
If y'all still see issues today, post here or email me.
Support MineTexas, Buy Plus
Shop our Cafe Press Store
Or shop our Amazon Affiliate store.
Reply
#4
We're still having issues, bae.
I'M A CREEPY OLD MAN ON THE INTERNET AND YOU CAN'T STOP ME
Reply
#5
(11-07-2016, 03:53 PM)_Remnant_ Wrote: We're still having issues, bae.

Is it better or worse than before?
Support MineTexas, Buy Plus
Shop our Cafe Press Store
Or shop our Amazon Affiliate store.
Reply
#6
Much, much worse.
I'M A CREEPY OLD MAN ON THE INTERNET AND YOU CAN'T STOP ME
Reply
#7
Some things I have noticed....

Ok, I'm new and a bit ignorant but I have noticed something since the lag began.

1) When night falls, I get bum rushed by no less than 6-9 mobs at my base. I don't have a lot of light source up, but they appear in much larger quantities than before. 

2) My farm regrows in a very short time. Before the lag, my farm (wheat, carrots, potatoes, and pumpkins) would take at least two days to regrow when I was nearby. Now they regrow much mush faster.

Thought I would point this out. Not sure if it could be related to the lag....

Tanman
Reply
#8
1pm-2pm GMT... Server has absolutely no lag or rubberbanding whatsoever.

There was a severe lack of hostile mob spawns tho.

These ppl were on, if it makes any difference.
[Image: nolag.jpg]
"Complexity, is just a lot of Simplicity"
Reply
#9
(11-08-2016, 08:52 AM)SirJohnChilcot Wrote: #GMTBestTimezone umad jewfags

very true be mad
help me change my tag
Reply
#10
To keep you guys updated, yesterday evening I changed the doMobSpawning gamerule to false. This absolutely removed all the lag we were having.

I was running some profiling on the server last night, and noticed a trend in the threads, mob spawning was taking most of the tick time. It wasn't consistent, but every so often, there would be a huge spike. Digging deeper, I eventually saw one of this in the java process monitor that pointed to a lot of calculations happening trying to spawn iron golems, and iron golem pathfinding. I checked on all the players online beforehand, and I noticed a common trend, Iron Golem farms. Huge ones, and a lot of them. Most with complex spawning areas that probably require a lot of calculations in order to spawn anything. When I made the change to the gamerule, the lag went away immediately and hasn't come back.

My current theory is that iron golem farms are the cause of the lag. They're relatively new, and growing in popularity.

I'm still not sure what to do about them long term, as the gamerule change is temporary.
Support MineTexas, Buy Plus
Shop our Cafe Press Store
Or shop our Amazon Affiliate store.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)